9th June 2020

Cloud Servers Network degradation in some of our locations

We're currently investigating reports of increased latency and packet loss in some of our datacentres and will continue to post updates to our status page as more information becomes available

Update - [06/09/2020 - 06:11PM MDT We're still monitoring this incident and are continuing to work with our affected Datacentres to resolve this issue as quickly as possible.

Update - [06/09/2020 - 06:41PM MDT] We are seeing services return to normal. As yet, we have not received a formal all clear from our partner or an explanation for the outage. We are continuing to monitor the situation, if you experience any further issues please contact our support team.