29th July 2020

Cloud Servers DAL-A network maintenance

Start Date: Wednesday 29-Jul-2020 07:00 UTC

End Date: Wednesday 29-Jul-2020 11:00 UTC

There's currently a network maintenance ongoing in Dallas A location. Servers should be available once it's done.

Update 15:00 GMT:

Unexpected issue arose during network maintenance and our engineers are working to resolve this as soon as possible.

Update 15:20 GMT:

Maintenance is complete and all servers should be back online.


If you have any questions or concerns, please contact support@VPS.NET