2nd November 2020

Cloud Servers Scheduled maintenance in ATL-G, NYC-C and SLC-K

We're in a process of scheduled maintenance in the ATL-G, NYC-C and SLC-K locations. Your VPS will be unavailable for a short period of time.

Update 8am GMT:

ATL-G maintenance completed

Update 12:18pm GMT

NYC-C maintenance completed

Update 2:15pm GMT

SLC-K maintenance completed