13th May 2021

Cloud Servers Title: Outage on Dallas and Phoenix facility

Title: Outage on Dallas and Phoenix facility

Date: 13/05/2021

We are currently experiencing an incident at our Dallas and Phoenix facility.

Our Technical teams have been engaged and are investigating as a priority.

UPDATE @ 18:30 UTC - We are continuing to investigate the issue and will post updates as they become available. We apologise for any inconvenience this may cause.

UPDATE @ 19:45 UTC - We are still continuing to investigate the issue, our network team is working diligently on a resolution. Again we apologise for any inconvenience this is causing.

UPDATE @ 22:10 UTC - Machines are now available in Dallas - work is still progressing on Phoenix and Los Angeles

UPDATE @ 22:50 UTC - All services are confirmed and tested to be back fully operational now in all affected data centres. We thank you for you patience regarding this issue