16th September 2023

(Chicago) - CHI-C Unavailable

Title (Chicago) - CHI-C Unavailable
Date Saturday 16 September 2023
Start time 03:18 UTC

We are currently experiencing an incident that is impacting our (Chicago) - CHI-C. Our Technical teams have been engaged and are investigating as a priority.

Update Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @06:40 UTC This has been resolved.